Response times have remained within expected ranges today during our monitoring. We are moving our affected components back to operational and marking the issue as resolved.
Posted Nov 19, 2025 - 16:42 MST
Update
We are still in a monitoring state and have noted healthy response times today. We will still keep an eye on things for today and will update at end of business 5pm PDT.
Posted Nov 19, 2025 - 10:08 MST
Monitoring
After our optimization efforts, we still anticipated a significant amount of time for the migration to execute. However it processed much faster than anticipated and the fix has been deployed to all environments. We remain in a monitoring state and will reconvene at start of business (Hirevue HQ 10am EST) to address any problems as traffic picks up for candidates and customers.
Posted Nov 18, 2025 - 20:29 MST
Update
After further optimization the team feels confident to make the necessary database adjustments to resolve the issue now. This will take a considerable amount of time and we will continue to monitor the progress to ensure the database migration runs successfully. We will enact our testing plan as soon as the databases are in a state to test, and we see an uptick in traffic.
Posted Nov 18, 2025 - 19:54 MST
Update
The timeline has been extended until 9pm PDT to deploy the fix to all environments. Updates to follow after that time.
Posted Nov 18, 2025 - 17:19 MST
Update
We are on track to deploy the fix within the hour to our EU and AU environments first. Our US environment will follow shortly some time after 5pm PDT.
Posted Nov 18, 2025 - 16:42 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 15:33 MST
Investigating
Earlier today we received reports of timeouts in regards to candidates being sent assessment OnDemand. Through our investigation recent logs show execution timeouts and server response delays, with a significant spike in assessment errors. We have identified a fix and plan to deploy that within the next several hours.
Posted Nov 18, 2025 - 15:19 MST
This incident affected: T2O (.com - USA) (Assessments, ATS Integrations), T2O (.eu - Europe) (Assessments, ATS Integrations), and T2O (.au - Australia) (Assessments, ATS Integrations).