EU/AU Environment Service Degradation

Incident Report for Hirevue

Resolved

We have resolved the issue and restored the assessment service back to operational.
Posted Jul 30, 2026 - 03:43 MDT

Identified

The issue has been identified and we are working bringing performance back to operational.
Posted Jul 30, 2026 - 00:03 MDT

Investigating

We are currently investigating a service degradation with regards to assessments within our EU/AU environment.
Posted Jul 29, 2026 - 23:21 MDT
This incident affected: T2O (.eu - Europe) (Assessments) and T2O (.au - Australia) (Assessments).