Unexpected Incident: Users are unable to schedule Microsoft Teams interviews T2O

Incident Report for HireVue

Resolved

The incident has been resolved and a fix is in place in all T2O environments: US, AU and EU. Our team will evaluate any cleanup needed and produce the Root Cause Analysis.
Posted Jul 01, 2025 - 12:25 MDT

Monitoring

A fix has been implemented in the US and AU regions for T2O. We are monitoring on our side. We are working to deploy the fix in EU.

Once the fix is in place across the board, we will evaluate any cleanup needed accordingly.
Posted Jul 01, 2025 - 12:12 MDT

Identified

The issue has been identified and we are releasing a fix to the US, EU and AU environments now. We will provide an update once the fix is complete.
Posted Jul 01, 2025 - 10:51 MDT

Investigating

We are experiencing a service disruption with Video Interviewing within our US, EU and AU regions of T2O.

Customers are unable to manually schedule Live Microsoft Teams interviews in T2O. Candidates ares unable to self schedule Live Microsoft Teams interviews in T2O.

We are making every effort to reduce the impact and length of the disruption. We apologize for any inconvenience this may cause, and we thank you for your understanding.

Individual system components are listed below.
Posted Jul 01, 2025 - 10:09 MDT
This incident affected: T2O (.com - USA) (Interviews - Live), T2O (.eu - Europe) (Interviews - Live), and T2O (.au - Australia) (Interviews - Live).