Unexpected Errors in T2O EU

Incident Report for HireVue

Resolved

After continuous monitoring we have seen performance in our EU environment stabilize and are marking this incident as resolved.
Posted Sep 05, 2025 - 13:44 MDT

Monitoring

With the completion of the maintenance we are seeing significant improvement in load times in the EU environment. Performance seems to be returning to normal and the slow downs & errors have been mitigated.

We will continue to monitor for any additional concerns with the changes made and again we apologies for any inconvenience.
Posted Sep 05, 2025 - 12:52 MDT

Update

We have completed maintenance and the T2O EU environment is back up but still experiencing slowdowns. We are working on deploying the additional resources.
Posted Sep 05, 2025 - 12:44 MDT

Update

We are taking the T2O EU environment down briefly for database maintenance to add additional capacity.
Posted Sep 05, 2025 - 11:51 MDT

Identified

We have identified one of the primary issues and are working on a solution. We are gathering and deploying additional resources to resolve the issue in the short term.
Posted Sep 05, 2025 - 11:49 MDT

Investigating

We are currently investigating a slowdown and errors when accessing the Hirevue T2O application in our EU environment.

We are actively working on resolving this disruption. We apologize for any inconvenience and thank you for your understanding!
Posted Sep 05, 2025 - 09:39 MDT
This incident affected: T2O (.eu - Europe) (Admin / Recruiter, Analytics, Assessments, Evaluations, Interviews - CodeVue, Interviews - Live, Interviews - On Demand).