Intermittent slow and nonresponsive page loads

Incident Report for HireVue

Resolved

We have resolved the incident which was a result of a high database load due to a scheduled process.
Posted May 11, 2025 - 02:58 MDT

Update

We are continuing to work on a fix for this issue.
Posted May 11, 2025 - 02:19 MDT

Identified

We believe we have identified the cause and are working on resolving the issue as soon as possible.
Posted May 11, 2025 - 01:55 MDT

Investigating

The Hirevue dashboard and candidate experience is currently experiencing intermittent slowly loading and nonresponsive pages. We are working to understand and fix this issue as soon as possible.
Posted May 11, 2025 - 00:59 MDT
This incident affected: T2O (.com - USA) (Admin / Recruiter, Analytics, API, Assessments, ATS Integrations, Email, Evaluations, Interviews - CodeVue, Interviews - Live, Interviews - On Demand, Messaging - SMS, Messaging - Whatsapp, Scheduling / Calendar Integration, Single Sign-On (SSO)).